You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
tde-packaging/ubuntu/maverick_automake/applications/keep/debian/patches/kubuntu_01_kdepot.diff

21 lines
972 B

diff -Nur keep-0.4.0/admin/cvs.sh keep-0.4.0.new/admin/cvs.sh
--- keep-0.4.0/admin/cvs.sh 2006-09-23 01:51:35.000000000 +0200
+++ keep-0.4.0.new/admin/cvs.sh 2006-12-05 16:29:23.000000000 +0100
@@ -537,6 +537,8 @@
if test -z "$PREPARETIPS"; then PREPARETIPS=preparetips ; fi
export EXTRACTRC PREPARETIPS
+kdepotpath=/usr/include/tde/kde.pot
+
for subdir in $dirs; do
test -z "$VERBOSE" || echo "Making messages in $subdir"
(cd $subdir
@@ -554,7 +556,6 @@
fi
perl -e '$mes=0; while (<STDIN>) { next if (/^(if\s|else\s|endif)/); if (/^messages:/) { $mes=1; print $_; next; } if ($mes) { if (/$\\(XGETTEXT\)/ && / -o/) { s/ -o \$\(podir\)/ _translatorinfo.cpp -o \$\(podir\)/ } print $_; } else { print $_; } }' < Makefile.am | egrep -v '^include ' > _transMakefile
- kdepotpath=${includedir:-`kde-config --expandvars --install include`}/kde.pot
if ! test -f $kdepotpath; then
kdepotpath=`kde-config --expandvars --prefix`/include/kde.pot
fi