You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
tde-packaging/dilos/dependencies/avahi-tqt/debian/rules

21 lines
591 B

#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
# Ensure at build time that the library has no dependencies on undefined
# symbols, and speed up loading.
export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) -Wl,-z,defs
# -Wl,-O1
# Build options
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_SKIP_RPATH="OFF" \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DWITH_ALL_OPTIONS="ON" \
-DCMAKE_C_COMPILER=gcc \
-DLIB_SUFFIX="/$(DEB_HOST_MULTIARCH)" \
-DWITH_GCC_VISIBILITY="OFF"