You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

50 lines
1.6 KiB

From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
Date: Wed, 13 May 2015 16:09:21 -0400
Subject: avoid self-describing as a beta
Using autoreconf against the source as distributed in tarball form
invariably results in a package that thinks it's a "beta" package,
which produces the "THIS IS A DEVELOPMENT VERSION" warning string.
since we use dh_autoreconf, i need this patch to avoid producing
builds that announce themselves as DEVELOPMENT VERSIONs.
See discussion at:
http://lists.gnupg.org/pipermail/gnupg-devel/2014-November/029065.html
---
autogen.sh | 4 ++--
configure.ac | 4 +---
2 files changed, 3 insertions(+), 5 deletions(-)
diff --git a/autogen.sh b/autogen.sh
index 37edfc6..2dff9cd 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -228,8 +228,8 @@ if [ "$myhost" = "find-version" ]; then
rvd=$((0x$(echo ${rev} | head -c 4)))
else
ingit=no
- beta=yes
- tmp="-unknown"
+ beta=no
+ tmp=""
rev="0000000"
rvd="0"
fi
diff --git a/configure.ac b/configure.ac
index c1b66d6..05a902a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,9 +36,7 @@ m4_define([mym4_revision], m4_esyscmd([git branch -v 2>/dev/null \
| awk '/^\* / {printf "%s",$3}']))
m4_define([mym4_revision_dec],
m4_esyscmd_s([echo $((0x$(echo ]mym4_revision[|head -c 4)))]))
-m4_define([mym4_betastring],
- m4_esyscmd_s([git describe --match 'pinentry-[0-9].[0-9].*[0-9]' \
- --long| awk -F- '$3!=0{print"-beta"$3}']))
+m4_define([mym4_betastring],[])
m4_define([mym4_isgit],m4_if(mym4_betastring,[],[no],[yes]))
m4_define([mym4_full_version],[mym4_version[]mym4_betastring])