You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

187 lines
7.4 KiB

#!/bin/sh
# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
# Copyright 2009, 2010, 2011, 2012, 2013, 2014, 2015 Eric Hameleers, Eindhoven, Netherlands
# Copyright 2015-2017 Thorn Inurcide
# Copyright 2015-2017 tde-slackbuilds project on GitHub
# All rights reserved.
#
# Permission to use, copy, modify, and distribute this software for
# any purpose with or without fee is hereby granted, provided that
# the above copyright notice and this permission notice appear in all
# copies.
#
# THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
# IN NO EVENT SHALL THE AUTHORS AND COPYRIGHT HOLDERS AND THEIR
# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
# USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
# OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
# SUCH DAMAGE.
PRGNAM=koffice
VERSION=$TDEVERSION
BUILD=${BUILD:-1}
TAG=${TAG:-_tde}
source ../../get-source.sh
getsource_fn
untar_fn
## clang build
## ../chalk/plugins/filters/colorsfilters/kis_brightness_contrast_filter.cpp:243:40: error: non-constant-expression cannot be narrowed from type 'int' to 'TQ_UINT8' (aka 'unsigned char') in initializer list [-Wc++11-narrowing]
## commit 7994981
patch -p0 -N << EOF || true
--- chalk/plugins/filters/colorsfilters/kis_brightness_contrast_filter.cpp
+++ chalk/plugins/filters/colorsfilters/kis_brightness_contrast_filter.cpp
@@ -243,1 +243,1 @@
- TQ_UINT8 weights[2] = {MAX_SELECTED - selectedness, selectedness};
+ TQ_UINT8 weights[2] = {(TQ_UINT8)(MAX_SELECTED - selectedness), selectedness};
--- chalk/plugins/filters/colorsfilters/colorsfilters.cpp
+++ chalk/plugins/filters/colorsfilters/colorsfilters.cpp
@@ -212,1 +212,1 @@
- TQ_UINT8 weights[2] = {MAX_SELECTED - selectedness, selectedness};
+ TQ_UINT8 weights[2] = {(TQ_UINT8)(MAX_SELECTED - selectedness), selectedness};
@@ -306,1 +306,1 @@
- TQ_UINT8 weights[2] = {MAX_SELECTED - selectedness, selectedness};
+ TQ_UINT8 weights[2] = {(TQ_UINT8)(MAX_SELECTED - selectedness), selectedness};
--- chalk/plugins/filters/colorsfilters/kis_perchannel_filter.cpp
+++ chalk/plugins/filters/colorsfilters/kis_perchannel_filter.cpp
@@ -257,1 +257,1 @@
- TQ_UINT8 weights[2] = {MAX_SELECTED - selectedness, selectedness};
+ TQ_UINT8 weights[2] = {(TQ_UINT8)(MAX_SELECTED - selectedness), selectedness};
--- chalk/plugins/filters/levelfilter/kis_level_filter.cpp
+++ chalk/plugins/filters/levelfilter/kis_level_filter.cpp
@@ -198,1 +198,1 @@
- TQ_UINT8 weights[2] = {MAX_SELECTED - selectedness, selectedness};
+ TQ_UINT8 weights[2] = {(TQ_UINT8)(MAX_SELECTED - selectedness), selectedness};
--- filters/kspread/excel/sidewinder/cell.cpp
+++ filters/kspread/excel/sidewinder/cell.cpp
@@ -120,1 +120,1 @@
- char buf[3] = { 'A'+(d/26), 'A'+(d%26), 0};
+ char buf[3] = { (char)('A'+(d / 26)), (char)('A'+(d % 26)), 0};
--- filters/kword/rtf/import/rtfimport.cpp
+++ filters/kword/rtf/import/rtfimport.cpp
@@ -1270,1 +1270,1 @@
- char tmpch[2] = {token.value, '\0'};
+ char tmpch[2] = {(char)(token.value), '\0'};
EOF
## Workaround to prevent chalk/krita crashing when loading PNGs it has saved
## Awaiting fix for koffice issue 20
patch -p0 << EOF
--- filters/chalk/png/kis_png_converter.cpp
+++ filters/chalk/png/kis_png_converter.cpp
@@ -202,4 +202,7 @@
// read all PNG info up to image data
png_read_info(png_ptr, info_ptr);
+#if PNG_LIBPNG_VER >= 10600
+ png_set_invalid(png_ptr, info_ptr, PNG_INFO_iCCP);
+#endif
// Read information about the png
EOF
## fix chalk crashing -
## - set liblcms as a direct dependency - see issue 37 for details
sed -i '23iKDE_CXXFLAGS = $(LCMS_LIBS)' chalk/Makefile.am
## - when launched from Applications menu
sed -i "s|Exec=.*$|Exec=$INSTALL_TDE/bin/chalk %U|" chalk/chalk.desktop
## building with installation directory /usr - see issue #43 for details
[[ $INSTALL_TDE == /usr ]] && \
{ mv $TQTDIR/lib$LIBDIRSUFFIX/libtqt-mt.la $TQTDIR/lib$LIBDIRSUFFIX/libtqt-mt.la-bak 2>/dev/null || true
}
## fix build problem for karbon - see issue 40 for details
sed -i 's|(Magick-config|(Wand-config|' configure.in.in
## revert name 'chalk' to 'krita' - option set in BUILD-TDE.sh
## but only if selected to be built at this time
[[ $(cat $TMPVARS/Krita_OPTS) == *krita* && $(cat $TMPVARS/DO_NOT_COMPILE) != *krita* ]] && {
echo -e "\n Reverting chalk to krita .. \n"
## Rename directories and files:
find . -name "*chalk*" |sort -r|xargs rename chalk krita
mv "krita/doc/Developing Chalk Plugins.odt" "krita/doc/Developing Krita Plugins.odt"
## Rename contents:
find . -type f -exec sed -i -e 's/chalk/krita/g;s/CHALK/KRITA/g;s/Chalk/Krita/g' {} \;
sed -i 's|Swedish for krita|Swedish for chalk|' krita/README
} || sed -i 's|krita|chalk|' $TMPVARS/DO_NOT_COMPILE # otherwise chalk won't be in the DO_NOT_COMPILE list and chalk libraries will be built
## Don't need translation files unless additional language == Polish
[[ I18N != *pl* ]] && sed -i '/pl/d' kexi/tools/{add,delete}_column/Makefile.am
## This isn't actually needed, but it's reassuring to see from the configure output that the filter is being built ..
sed -i 's|KFORMULA$COMPILE_FILTER_KUGAR|&$COMPILE_FILTER_KRITA$COMPILE_FILTER_KIVIO$COMPILE_FILTER_KEXI|' filters/configure.in.mid
[[ $(cat $TMPVARS/DO_NOT_COMPILE) == *kross* ]] && SCRIPTING=--disable-scripting
## Add man pages for development builds
[[ $TDEVERSION != 14.0.12 ]] && \
MANDIR=--mandir=$INSTALL_TDE/man
listdocs_fn
ltoolupdate_fn
chown_fn
cd_builddir_fn
DO_NOT_COMPILE=$(cat $TMPVARS/DO_NOT_COMPILE) \
CFLAGS="$SLKRCFLAGS" \
CXXFLAGS="$SLKRCFLAGS" \
CC=$COMPILER \
CXX=$COMPILER_CXX \
../configure \
--prefix=$INSTALL_TDE \
${MANDIR:-} \
--disable-rpath \
${SCRIPTING:-} \
--enable-closure
make_fn
installdocs_fn
[[ $TDEVERSION != 14.0.12 ]] && mangzip_fn
strip_fn
mkdir_install_fn
doinst_sh_fn
echo "
# HOW TO EDIT THIS FILE:
# The 'handy ruler' below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
$PRGNAM: KOffice is a collection of office applications linked together by a
$PRGNAM: common basis, which assures that all office applications can work
$PRGNAM: together.
$PRGNAM:
$PRGNAM: You can, for instance, insert a spreadsheet in a thesis without
$PRGNAM: leaving the document. Editing [the spreadsheet] happens _inside_
$PRGNAM: the thesis.
$PRGNAM:
$PRGNAM:
$PRGNAM:
$PRGNAM:
" > $PKG/install/slack-desc
makepkg_fn
## restore libtqt-mt.la
[[ $INSTALL_TDE == /usr ]] && \
{ mv $TQTDIR/lib$LIBDIRSUFFIX/libtqt-mt.la-bak $TQTDIR/lib$LIBDIRSUFFIX/libtqt-mt.la 2>/dev/null || true
}