You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

118 lines
4.0 KiB

This file contains ambiguous Unicode characters!

This file contains ambiguous Unicode characters that may be confused with others in your current locale. If your use case is intentional and legitimate, you can safely ignore this warning. Use the Escape button to highlight these characters.

#!/bin/sh
# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
# Copyright 2009, 2010, 2011, 2012, 2013, 2014, 2015 Eric Hameleers, Eindhoven, Netherlands
# Copyright 2015-2017 Thorn Inurcide
# Copyright 2015-2017 tde-slackbuilds project on GitHub
# All rights reserved.
#
# Permission to use, copy, modify, and distribute this software for
# any purpose with or without fee is hereby granted, provided that
# the above copyright notice and this permission notice appear in all
# copies.
#
# THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
# IN NO EVENT SHALL THE AUTHORS AND COPYRIGHT HOLDERS AND THEIR
# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
# USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
# OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
# SUCH DAMAGE.
PRGNAM=mp4v2
VERSION=2.1.1
BUILD=${BUILD:-1}
TAG=${TAG:-}
ARCHIVE_TYPE="tar.gz"
SRCURL="https://github.com/enzo1982/$PRGNAM/archive/v$VERSION.$ARCHIVE_TYPE"
source ../../get-source.sh
getsource_fn
untar_fn
## patch for gcc10 - error: narrowing conversion of mp4v2::util::SubtitleUtility::LC_LIST from unsigned int to int, etc..
## thanks to https://bugs.gentoo.org/723098
patch -N -p0 << EOF || true
--- libutil/Utility.cpp
+++ libutil/Utility.cpp
@@ -492,1 +492,1 @@
- switch( code ) {
+ switch( static_cast<unsigned int>( code ) ) {
--- util/mp4art.cpp
+++ util/mp4art.cpp
@@ -379,1 +379,1 @@
- switch( code ) {
+ switch( static_cast<unsigned int> ( code ) ) {
--- util/mp4chaps.cpp
+++ util/mp4chaps.cpp
@@ -678,1 +678,1 @@
- switch( code ) {
+ switch( static_cast<unsigned int> ( code ) ) {
--- util/mp4file.cpp
+++ util/mp4file.cpp
@@ -192,1 +192,1 @@
- switch( code ) {
+ switch( static_cast<unsigned int>( code ) ) {
--- util/mp4subtitle.cpp
+++ util/mp4subtitle.cpp
@@ -167,1 +167,1 @@
- switch( code ) {
+ switch( static_cast<unsigned int>( code ) ) {
--- util/mp4track.cpp
+++ util/mp4track.cpp
@@ -775,1 +775,1 @@
- switch( code ) {
+ switch( static_cast<unsigned int>( code ) ) {
EOF
listdocs_fn
## create mp4v2.pc.in after the installation libs and include directories have been set
sed -i '/^configure_pkg_config_file/d' CMakeLists.txt
sed -i 's|install.*mp4v2.pc.*$|configure_pkg_config_file(mp4v2.pc.in)\n&|' CMakeLists.txt
## cmake build needs to be in top level directory for created project.h file installation
cmake ${G_NINJA:-} \
-DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
-DCMAKE_CXX_COMPILER=$COMPILER_CXX \
-DBUILD_SHARED="ON" \
-DBUILD_UTILS="ON" \
.
make_fn
installdocs_fn
strip_fn
mkdir_install_fn
echo "
# HOW TO EDIT THIS FILE:
# The 'handy ruler' below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
$PRGNAM: mp4v2 (Create and modify mp4 files)
$PRGNAM:
$PRGNAM: The MP4v2 library provides an API to create and modify mp4 files as
$PRGNAM: defined by ISO-IEC:14496-1:2001 MPEG-4 Systems. This file format
$PRGNAM: is derived from Apple's QuickTime file format that has been
$PRGNAM: used as a multimedia file format in a variety of platforms and
$PRGNAM: applications. It is a very powerful and extensible format that can
$PRGNAM: accommodate practically any type of media.
$PRGNAM:
$PRGNAM:
$PRGNAM:
" > $PKG/install/slack-desc
makepkg_fn